Feedback-Thread zur Vorabversion

Alles über die inoffizielle AoE II-Erweiterung

Moderatoren: Barbarossa, Entdecker

Hallo zusammen! Bitte postet hier alles zur AddOn-Vorabversion, seien es Eindrücke, Bugberichte, Installationsprobleme, Kritiken oder Vorschläge :)

Den aktuellen Stand könnt ihr außerdem in unserem Bugtracker verfolgen. Falls ihr direkt dort Fehler melden (oder kommentieren) möchtet, könnt ihr euch über "Neues Konto anmelden" gern auch einen eigenen Account anlegen.
Ist schon was her als ich es drauf hatte... aber ich kann zumindes sagen das die Installation bestens funktioniert hatte, zu dem rest kann ich erst wieder was sagen wenn ichs nochmals lade, werd ich die tage (bald) mal machen
Also hab mal so ein wenig ausprobiert...

Insgesamt finde ichs Top gelungen besonders die Schiffe sind alle super geil geworden :D :super:
Die Intstallation ist noch einfacher als zuvor, mit dem Lancher und funktioniert top :super:

Nun aber zum größten harken:
Das Spiel Stürzt ab sobald man ein Spiel beginnt

Ein Paar weitere auffälligkeiten wenn das Spiel dann doch läuft mit einer anderen Exe:
Der Phalangit kann bei mir nicht Kämpfen, aber ich weiß ja nicht, vll ist das auch so gewollt
Das Gewitter ging bei mir nicht, liegt vll an der Exe?
Das Skelett scheint Grafisch beim Kanpf nicht richtig Zentriert zu sein
Die Einquartierungsfahnen sind bei der Festung nicht immer Richtig und beim Almut fehlen diese ganz
Auch die Schneegrafiken fehlen bei den Gebäuden ganz oder sitzen nicht richtig
Flammen fehlen Teilweise auch komplett

In der Gamedata sind nicht alle Objekte SLP oder Bina dateien
Kaisergott hat geschrieben:
Dienstag 2. Januar 2018, 01:39
Nun aber zum größten harken:
Das Spiel Stürzt ab sobald man ein Spiel beginnt
Frohes Neues! :hallo:
Danke erstmal, freut mich persönlich schon mal ganz besonders dass die neuen Schiffe positiv hervorstechen. :super:

Nur so ins Blaue: sicher dass du den aktuellsten Userpatch 1.5 korrekt installiert hast?
Genau das Problem (nach einmaligem erfolgreichem Map-Test plötzlich Absturz bei jedwedem Spielstart) hatte ich nämlich auf meinem Lappi auch eben, bis mir aufgefallen ist, dass ich aus Versehen eine veraltete Patch.exe ausgeführt hatte.
Seit Korrektur und erneuter AddOn-Installation läuft es.
Hab da aber auch gerade mein Problem mit dem Absturz bei Gefechtsstart.

Patch neu installiert und den Installer durchrattern lassen, Spiel beendet sich.
Werds aus Zeitmangel morgen vermutlich einfach komplett neu installieren.

Aber der Techtree geht schonmal einwandfrei :D

Edit: Funktioniert nach komplettem Re-Install weiterhin nicht.
Hmm, das ist ja merkwürdig :(
Hab es auf einem weiteren System getestet, da hat es funktioniert. Habt ihr auch definitiv den UserPatch 1.5 (nicht 1.4 RC!) genommen?

Um weitere mögliche Probleme auszuschließen, hier meine (funktionierenden) UserPatch-Settings:
- Windowed mode support
- Port forwarding support
- Widescreen
- Darken mini-map grey
- Population caps to 1000
- Enable water animation
- Precision scrolling system
- Shift group appending
- New save filename format
- Multiple building queue

Vielleicht könnt ihr die einmal genau nachbauen, dann können wir das als Ursache schonmal ausschließen :)

Falls das nicht hilft: Könnt ihr nach dem Absturz einmal in die Windows-Ereignisanzeige gehen, dort unter "\Windows-Protokolle\Anwendung" nach dem entsprechenden Absturzereignis gucken (müsste irgendwo ganz oben auftauchen), und mir den kompletten Fehlertext kopieren?
So habe den Patch 1.5 mit deinen Einstellungen nochmals neu Installiert und diesmal die Orginal exe überspielt, statt eine extra exe für 1.5 anzulegen, so läuft es nun ohne Probleme.
Kaisergott hat geschrieben:
Mittwoch 10. Januar 2018, 18:48
und diesmal die Orginal exe überspielt, statt eine extra exe für 1.5 anzulegen
Ah ja, daran hat es sicher gelegen - das AddOn pickt sich immer die age2_x1.exe raus. Aber ich kann mal gucken, ob sich das irgendwie automatisch erkennen lässt, um derartige Probleme in Zukunft zu vermeiden :)
Läuft jetzt, war dann wohl doch nicht 1.5 vom Userpatch.
(Solche groben Fehler sind doch sonst nicht meine Art! :o )
Auf der Userpatch-Website bekommt man halt bei Download 1.4; für 1.5 muss man innerhalb der Textes auf der Homeseite bei der Meldung zu 1.5 auf 'click here' navigieren. :mad:

Also probier ich dann ab jetzt mal durch :rocktvoll:
Bei mir hat mit Userpatch 1.5 alles funktioniert! TOP, macht viel Spaß! :)

Einheiten und Gebäude, die ich bis jetzt getestet habe, machen soweit alles, was sie sollen. In der Renaissance haben die Armeen der Völker dann echt ein ziemlich abwechslungsreiches Erscheinungsbild, das finde ich super.

Beim Techtree gibt es einige Überlappungen mit den Söldnereinheiten, weil hinter manchen (nicht allen) noch "(Söldner)" steht, was dann teilweise über die nächste Einheit rutscht.
Habe eine Runde mit den Azteken gespielt und folgendes ist mir aufgefallen:

Der Sound, wenn ein Chamäleonkrieger daneben schießt, ist der Sound eines Skorpionbolzens, das wirkt dezent befremdlich.
Sein Elite-Upgrade ist auch nicht drin, stattdessen gibts das Upgrade zum Schweren berittenen Bogenschützen. Nach dessen Entwicklung ändert sich beim Chamäleonkrieger nichts.
Weiterhin fehlte das Icon für das Schmiede-Upgrade Rundschild.

Allgemeines:
Erst nach dem Bau einer Burg konnte ich in die Imperialzeit, Universität und Kloster reichten irritierenderweise nicht aus.
Der Tooltip unten links ist (in seiner ausführlichen Variante) nur in sichtbaren Gebiet transparent, in (nicht) erkundetem Gebiet ist sein Hintergrund schlicht schwarz.
Zum Techtree: Es irritert, dass Technologien, deren Vor-Tech (bspw. Daumenring für Brandpfeile) gesperrt ist, nicht gesperrt sind. Wenn dann Daumenring aufgrund von Platzmangel und nicht Entwickelbarkeit auch nicht im Tree auftaucht sieht das nicht so sauber aus.
Das Icon zum Palisadenwall fehlt. Als Upgrade im Dorfzentrum ist eines zu sehen, jedoch nicht beim Gebäude.

Ggf. haben einige Dinge auch mit dem Userpatch zu tun (schätze der Tooltip wäre sowas), da ich 1.5 jedoch vorher nicht gespielt habe, fällt mir das nicht auf.

Für die Schiffe gibts echt nochmal ein Sonderlob. Seekampf wird komplett anders und wird bei weitem nicht mehr so monoton aussehen :cool:
Ui, das ist ja ordentlich Feedback :super:
Und schön dass es jetzt funktioniert!

Ich schau mir die Bugs später mal an, die meisten sollten leicht zu beheben sein :)

Das mit den nicht-transparenten Hilfe-Boxen ist mir gar nicht aufgefallen, liegt sehr wahrscheinlich am UserPatch.
EDIT: Konnte es reproduzieren, das ist echt merkwürdig.
Nach einer Runde mit den Briten:

Beim Volkbonus für verringerte Kosten für Dorfzentren ist die Renaissance noch nicht erwähnt.
Armbrustschützen ließen sich sofort nach dem Eintritt in die Ritterzeit bauen, die Weiterentwicklung zum Armbrustschützen war aber noch da und entwickelbar, jedoch ohne Wirkung.
Den Palisadenwall konnte ich bauen, obwohl er laut Techtree gesperrt sein sollte.
Die Freibeuter nehmen einen vollen Platz im Transportschiff ein, keinen halben wie laut Tooltip.
Die Söldnereinheit Hobilar lässt sich nicht einquartieren, Transportkutschen ebenso.

Allgemeines:
In der Endstatistik taucht die Renaissance noch nicht auf, aber ich will da jetzt ungern ein Fass aufmachen, nur mal der Vollständigkeit wegen.
Es gibt keine brachen Felder mehr, sind Felder in der Warteschlange werden sie neu gesetzt, aber manuell muss man sie stets übers Menü.
Die Renaissance hat noch keinen erweiterten Tooltip.
Im Tooltip zur Weiterentwicklung zum Hauptturm stet, die Reichweite würde erhöht, was jedoch nicht zutrifft. Glaube, dass ist seit dem Grundspiel schon falsch.
Die Burg profititert nicht mehr von offensiven Fernkampf-Schmiede-Upgrades, soll das so sein?
Das offensive Fernkampf-Schmiede-Upgrade der Renaissance wirkt auch auf Türme, berittene Bogenschützen und Plänkler, der Tooltip ist also nicht passend.
Dragoner stehen in einer anderen Richtung, als aus der sie reitend kamen.
Langspieß in der Schmiede gibt nicht +1 ATK für Hellebardiere, über den Bonus gegen Kavallerie kann ich noch nichts sagen.
Wow, da hat sich ja schon ordentlich Feedback angesammelt! :super:
Freut mich aber auch erst schon einmal, dass es bei allen bisher läuft und gerade mein Lieblingskind und gefühltes Herzstück, die neue Flotte, gut ankommt. :-)
Es war uns durchaus klar, dass viele (unvoreingenomme) Augen mehr sehen werden als wenige, daher sind wir völlig damit zufrieden wenn nur lauter kleinere Sandkörnchen im noch uneingefahrenen Getriebe abzuarbeiten sind.

Vorab erklärend zu den Kritikpunkten:
ein paar kleinere Features haben wir bisher bewusst v.a. aus logistischen oder praktischen Gründen noch nicht bzw nur provisorisch integriert. Zb kommen erst demnächst noch die neuen Helden und viele neuartige Sounds, zb Raketengeräusche oder abgestufte Schusslaute für die nun verschiedenen Kanonengeschosstypen.


Zu einigen Punkten, zu denen ich selbst so ad hoc schon was (Klärendes) sagen kann:
Verborgener Text:
1) Beim Volkbonus für verringerte Kosten für Dorfzentren ist die Renaissance noch nicht erwähnt.
Es ist irgendwie (wohl angesichts der sonst sehr üppigen neuen Briten-Boni) untern Tisch gefallen, diesen AoC-Bonus auch noch auf die Renaissance auszudehnen. Aber da kaum Baukosten für DZs in der Ren. kaum balancerelevant sein dürften, könnten wir es eigentlich auch noch ergänzen.

2) Den Palisadenwall konnte ich bauen, obwohl er laut Techtree gesperrt sein sollte.
Da ist der Fehler eindeutig das Sperrsymbol, da der Palisadenwall (Upgrade des Holzwalls) für alle Völker verfügbar sein soll.

3) Das offensive Fernkampf-Schmiede-Upgrade der Renaissance wirkt auch auf Türme, berittene Bogenschützen und Plänkler, der Tooltip ist also nicht passend.
Tatsächlich ist in aller Regel (so auch hier) im Zweifel der Tooltip das korrekte Gewollte.
Von der Repetierarmbrust sollen tatsächlich alle Armbrustträger und Gebäude/Schiffe, deren (unsichtbare) Pfeilschützen theoretisch Armbruster sein können, profitieren.
Plänkler und ber. Bogis müssen also hier noch rausgenommen werden, da sie schließlich Speer- bzw. Bogenträger sind.

4) Dragoner stehen in einer anderen Richtung, als aus der sie reitend kamen.
Das war tatsächlich eine absichtliche Anpassung der Standing-SLP meinerseits nach den Alphatests, denn so zeigt die Pistole des Dragoners nach dem Lauf immer automatisch in die Lauf- also potenzielle Feindrichtung.
Da der Dragoner grafisch nun einmal so geschaffen wurde, dass er seine Pistole nicht nach vorne, sondern leicht querab richtet, hatte es mit dem vorigen Frame-Setting den unschönen Effekt, dass er sonst zwischen den Schusspausen jedesmal von einer Richtung in die andere wechselt. Dass er sich nun nach dem Laufen bloß einmalig in Lauerstellung dreht, war m.E. der deutlich akzeptablere Wermutstropfen.

5) Beim Techtree gibt es einige Überlappungen mit den Söldnereinheiten, weil hinter manchen (nicht allen) noch "(Söldner)" steht, was dann teilweise über die nächste Einheit rutscht.
Wie Alex kürzlich schon ganz richtig kombiniert hat, ist tatsächlich gar nicht gewollt, dass im Techtree der Appendix "Söldner" auftaucht, da ich ja schon die neuen orangenen Hintergründe eingeführt hab und die zur Hervorhebung ja völlig ausreichend hielt.
Das "... (Söldner)" hatte ich als späte Innovation nur für den Editor vorgesehen, damit man sie beim Setzen und Schaltern von den regulären Version unterscheiden kann. Age hat aber die ES-gewollte (und an sich recht praktische) Eigenheit, dass beim Fehlen einer Techtree-DLL automatisch die normale Name-DLL genommen wird.
Werde daher für die betreffenden Söldner noch die notwendige separate Techtree-DLL ergänzen. :)
Da schaut man mal eine Weile nicht vorbei und schon gibt's echt großartige Neuigkeiten :rocktvoll:

Hatte auch erst den falschen Patch installiert, aber nun läuft es einwandfrei.
Als ich den Technologiebaum angeschaut habe, fiel mir auf, dass der Tribok das Symbol des befestigten Walls hat.

Weiteres folgt, sobald ich mehr getestet habe.
Aber sieht schon mal alles sehr geil aus :) :super:


EDIT: Nach bissl testen:

Dateianhänge

Da war es ja gut dass ich mal etwas Privat-PR gemacht hab.
Sollte ich bei dem ein oder anderen Alteisen vllt auch noch machen, kann nicht schaden :D
Danke schon mal für ein weiteres kritische und hoffe auch dauerhaft begeistertes Augenpaar!

@bugs:

1. Oh kurios. Das mit dem Tribok ist bisher noch keinem aufgefallen. Da ist auch die Kartenfarbe falsch (Gebäude), daher weht wohl der Wind.
2. Jap, da hab ich die Help-DLL vergessen. Ist inzwischen schon behoben :)
3. Nee, die 500 Stein sind beabsichtigt, um den Ressourcenverbrauch bei den Schiffen etwas weniger einseitig zu gestalten. Hintergrund ist, dass die Große Kriegsgaleere ja eine Galeere ist, die zum Katapultschiff wird, das Steine schleudert.
Danke für das viele Feedback! :cool:

Eine Version mit einigen Bugfixes (v.a. verbesserten TechTree-Grafiken) ist bereits auf dem Server. Der Launcher sollte diese automatisch erkennen und zur Installation anbieten.

Den aktuellen Stand könnt ihr nun auch in unserem nagelneuen Bugtracker verfolgen. Falls ihr direkt dort Fehler melden (oder kommentieren) möchtet, könnt ihr euch über "Neues Konto anmelden" gern auch einen eigenen Account anlegen. :)